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UW ASIC DESIGN TEAM: Cadence Tutorial

Description:

PartI: Layout & DRC of a CMOS inverter.
Part II: Extraction & LVS of a CMOS inverter.
Part III: Post-Layout Simulation.

The Cadence IC design flow is depicted below.

In the first Cadence tutorial we covered the “Schematic Capture,” “Create Symbol,” and “Simulation:
Pre-Extraction” steps of the IC design flow.

In Part I of this tutorial we cover the “Layout Design” and “Design Rule Check (DRC)” steps of the IC
design flow.

In Part II of this tutorial we cover the “Parasitics Extraction” and “Layout Vs. Schematic” steps of the IC
design flow.

In Part III of this tutorial we cover the final “Post-Layout Simulation” step of the IC design flow.
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© 2005 UW ASIC Design Team



To proceed we will modify the schematic of our CMOS inverter to prepare it for layout:

1. First, remove all DC voltage sources from the schematic and add two new pins: VDD and VSS.
Wire the VDD and VSS pins to the appropriate terminals of the CMOS inverter. Resize the
NMOS channel width to 600n M.

2. Next, delete the symbol cell view and create a new symbol cell view, which will now include the
VDD and VSS pins.
3. The new symbol will automatically appear in the inverter_sim schematic. Add an external power

supply to the inverter_sim schematic and attach the external power supply to the VDD and VSS
pins of the new symbol.

PART I: LAYOUT AND DRC OF A CMOS INVERTER

LAYOUT:
1. From the icfb window select: Tools > Library Manager.
2. In Library Manager select the tutorials library, the inverter cell, then: File > New > Cell View.

® Create Mew File

Ok Cancel | Defaults Help

Library Mame tutorials

Cell Hame ilnverter

View Hame Layout,

Tool Virtuoso

Library path file

4 fuwasic feadence Stutorialslfods. Lik

(a) In the Tool drop down menu select Virtuoso, as depicted above.
(b) Click OK.

In a few moments the LSW (Layer Selection Window) and Virtuoso® windows will appear. LSW
is used to select the different materials that the CMOS inverter will be composed of. Virtuoso® is
the tool in which we will draw the CMOS inverter layout.

3. In Virtuoso® press “i”.

In the Create Instance window click Browse.

In the Library Browser — Create Instance window, select the CMCpcells library and the spchmos

cell view.

As shown below, in the “Create Instance” window,

(a) Select Add Substrate Contact?. A Substrate Contact Position label appears.
(b) Select “Bottom” for Substrate Contact Position.

(c) Select Add Substrate Well?.

(d) You may now return to the Virtuoso® window and lay down the spcnmos symbol.
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¥ Create Instance

Hide | Cant:el| Defaults| Help|
Library |CMCpcells Brovrse |
Cell spormos

View | Layout]

Hames | 1L

Mosaic Rows L Columns | L
Deitay (1.3 Deitax1.84
Magnification | i

21k Rotate Ak Sideways =2 upside Duﬂ

Gate Width |EDDn ]

Gate Length 18000 1

Multiplication Factor (m)
Gate Splitting _
Left Contacts | |
Right Contacts | |
fuld substrate contact? n
Substrate Contact Position . Top 4 Bottom
Add substrate well? |}

Bulk MHode Connection(s) |E

4. Repeat the step 3 to lay down an instance of the Spcpmos symbol in Virtuoso®, only this time
select Top for Substrate Contact Position and change the Gate Width to 800n M.

5. Organize the spcnmos and spcpmos symbols as depicted below.
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6. Using the mouse, select both the spcnmos and the spcpmos symbols. Then:

(a) Select: Edit > Hierarchy > Flatten...
(b) Select Flatten Pcells

X Flatten
OK | Cancel| Apply Help
Hatten Mode ¥ one level displayed levels

Fatten Pcellzs MW
Preserve PFins

Preserve ROD Objects

(c) Click OK.
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In Virtuoso®, select: Options > Display
(a) Change the Minor spacing to 0.01.
(b) Change the Major spacing to 0.05.
(c) Change the X Snap Spacing to 0.01.
(d) Change the Y Snap Spacing to 0.01.

All units are in pum.

X Dis play Options

OK | cancel | Defaults| Apply | He|p|
Display Controls Grid Controls

M Open to Stop Level | Nets Type - none 4 dots - lines
H Axes _| Access Edges A

i i 0. o1
N Path Borders _| Instance Pins HIRGE Shating L
_| Instance Origins _| &rray Icons Major Spacing 0.0%
H EIP Surround B Label Origins ¥ Snap Spacing 0.0L
_| Pin Hames M Dynamic Hilight ¥ Snap Spacing 0ol
_| Dot Pins B Het Expressions 8
_| Use True BBox _| Stretch Handles Filter
_| Cross Cursor Size _g_ Style _EEF_W |
Show Mame Of . -instance 4 master Snap Mates
frray Displa :

Yy Sy Display Levels Pt orthogonal . |
4 Full Start |
| Edit orthogonal
.~ Border ]
Sto

-~ aource P |

save To |

Load From |

¥ Cellview - Library - Tech Library - File |~f. cdsenv

Delete From

(e) Click OK.
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In Virtuoso®, select: Options > Layout Editor
(a) Change the Apeture to 0.01.

# Layout Editor Options
oK Cancel | Defaults| Apply Help
Editor Controls Gravity Controls
B Repeat Commands Gravity On

Display Reference Point

all
W Auto Set Reference Point | | 17P%S M none

B Recursion Check M centerdine M edge
Maintain Connections M midpoint W vertex
Sticky Met M end H nexus

B Ahut Server M pin

Aperture | 0.01 |Depth 1]

Conic 3ides 2'3 Bounce X '] Bounce ¥ '3
File v/ cdsens
Save To Load From
(b) Click OK.

Connect the gates of the two transistors:

(a) Use the Ruler button to mark the location of the bottom of the red poly silicon gate of the
spcnmos symbol:

< Ruler button

(b) Delete the entire red poly silicon gate from the sSpcnmos symbol.
(c) Stretch the bottom of the red poly silicon gate of the Spcpmos symbol using the stretch button:

. & Stretch button

The red poly silicon gate should extend down to the location you marked using the ruler.

Both the spcnmos and spcpmos now share the same poly silicon gate as depicted below.

© 2005 UW ASIC Design Team



10.

11.

12.

Add metallization for the VDD and VSS pins:

(a) Select the metall | dg material from the LSW window, and use the Rectangle button to draw
two large metall rectangles as depicted below.

< Rectangle button
Add metal interconnects:

(a) Select the metall | dg material from the LSW window, and use the Rectangle button to draw
interconnects as depicted below.

Add VDD and VSS pins:

As depicted below, a pin appears as rectangles that has an X through it.
(a) Select the metall | pn material from the LSW window.

(b) In Virtuoso® select: Create > Pin

]
Step 9 & 10. Step 11, 12 & 13. Step 14 & 15.
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13.

14.

15.

16.

(¢) In the Create Pin Shape window:
(i) Enter VDD and VSS into the Terminal Names text box.
(ii) Select Pin Shape
(iii) Select Display Pin Name
(iv) Select inputOutput

X Create Shape Pin

Hide | Cancel Help |

Terminal Hames VID W53

Keep First Hame  wape [0 wonnen [0
Mode ¥ rectangle dot - -polygon - - circle auto pin SYIm pin
M Display Fin Hame Display Fin Name Option... |
110 Type input - output # inputOutput
switch - jumper
Snap Mode orthogonal -

Access Direction |l Top W Botiom W Left W Right

H Any | Hone
As ROD Object

FEOBE) Thwr rectl

(d) Lay down the VDD and VSS pins on the top and bottom, respectively, metallization as
depicted on the previous page.

Add the VOUT pin:

Using a procedure similar to Step 12 lay down the VOUT pin on the metal interconnect that
connects the two transistors, as depicted on the previous page. NB: Set the /O Type of the
VOUT pin to output.

Add some extra poly silicon beside the gate:

(a) Select the polyl | dg material from the LSW window, and use the Rectangle button to draw a
poly silicon square as depicted on the previous page.

Make a contact pad and metallization:

(a) Select the contact | dg material from the LSW window, and use the Rectangle button to draw
a 0.22 um by 0.22 um contact pad as depicted on the previous page.

(b) Select the metall | dg material from the LSW window, and use the Rectangle button to draw
a rectangular block of metallization that is the same size as the poly silicon square that was drawn
in Step 14.

(a) Move the contact pad and metallization, which were drawn in Step 15, onto the poly silicon
square, which was drawn in Step 14, as depicted below.

(b) Add a VIN pin on top of the polyl-contact-metall stack as depicted below. NB: Set the
I/0 Type of the VOUT pin to input.
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DRC:

Step 16. Step 16 (close up of poly-contact-metal-pin)

The layout of the CMOS inverter is now complete.

In Virtuoso® select: Verify > DRC ...

Any errors will be reported in the icfb window. The DRC should finish with zero errors.
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PART II: EXTRACTION AND LVS OF A CMOS INVERTER

EXTRACTION:

1.

In Virtuoso® select: Verify > Extract ...

(a) Click the Set Switches button.
(b) From the pop up list, select parasitic_caps and click OK.
(¢) You are now back at the Extractor window, click OK.

-

X Extractor

oK Cancel | Defaults Apply Help |
Extract Method # flat - macro cell full hier -_-incremental hier
Join Hets With Same MHame Echo Commands |
Switch Hames parasitic_caps Set Switches |

Run-Specific Command Fle

Inclusion Limit |1o0g

View Names Extracted extracted Excell |excell
Rules File | divaEXT. rul}

Rules Library B |cmosplE

Machine # local - remote Machine

Any errors will be reported in the icfb window. The Extraction should finish with zero errors.

A new view, named extracted, will now appear in the inverter cell.

© 2005 UW ASIC Design Team



LVS:
1. From Library Manager Open the extracted cell view.
2. From Virtuoso® select: Verify > LVS ...
(If an “LVS Form Contents Different” window appears select Form Contents and click OK)
3. In the LVS window: change the Priority to 20, as shown below, and click Run.

A “Analysis Job Succeeded” message will appear, click OK.

% Lvs RER]

Comimands Help | 17
Run Directory |LVS Browse
Create Netlist M schematic W extracted

Library tutorials tutorials

Call inverter inverter

View schematic extracted

Browse | Sel by Cursor | Browse | Sel by Cursor

Rules File dival¥Ws. rul Browsse

Rules Library W cnospls

LVS Options B Rewiring Device Fizing
Create Cross Reference M Terminals

Correspondence File neetutorialsl Aws corr file  Create

w

Switch Hames
Priority | 20 Run local
Run Output Error Display kMonitor Info

Backannotate Parasitic Prohe Build Analog Build Mixed

4. Though the LVS succeeded, it does not mean that the Layout matches the Schematic.

Click the Output button, shown above. The si.out text file is displayed. Check the contents of
the si.out text file for the following line: “The net-lists match.”

If the net-lists do not match, then there is an error in the layout. Fix the layout, and repeat the
Extraction.and LVS.

Tip: When the Extracted view is displayed in Virtuoso® you may toggling between Shift+f and
Ctrl+f to display the devices and parasitics that were identified by the extraction.
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PART I1I: POST LAYOUT SIMULATION

1. Open the inverter_sim schematic.
2. In Virtuoso® select: Tools > Analog Environment
3. Configure Analog environment as you did in the first Cadence tutorial, then in Analog

Environment select:
Setup > Environment

(a) In the Switch View List text book type the word extracted before the word schematic as

depicted below.
’x Environment Options
OK | Cancel |Defaults| Apply | Help |
Switch View List ce cmos_sch cmos. sch extracted schematic weriloga shdl
Stop View List spectre

Parameter Range Checking File
Analysis Order

Print Comments

userCmdLine Option

Automatic output log |

Use SPICE Hetlist Reader{spp): N N

Create Checkpoint File{cp): A e J 4 |

Start from Checkpoint Fle{rec): _|¥ [N
(b) Click OK.

(c) Click the Netlist and Run button.

This simulates the extracted view of the CMOS inverter. The waveform window will be displayed
as shown below.

< Netlist and Run button.
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& Waveform Window -- Cadence® Analog Design Environment (1) E]@

Active 22
Window Foom Axes Curves Markers Annotation Edit Tools Help

mouse L:awwiouseSingleSelec M: E:sevHetlistAndRun (‘s

=

Tip: In Virtuoso®, descend (Hot-key: e) into the inverter block of the inverter_sim schematic.
You will find that the extracted view is displayed.
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