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Software installation Welcome 

Welcome 
The ChainBuilder software is an important tool in improving ProASIC programmability. It enables you to program or test multiple 
devices (FPGAs, microcontrollers, or custom ICs) with a single header. The ChainBuilder software also reduces programming time 
and enables you to easily program Flash in a daisy chain. The ChainBuilder software provides two key benefits, the ability to pass 
through non-Flash devices to program APA device(s) in series and the ability to program multiple APA devices concurrently. 

The ability to pass through non-Flash devices enables you to use a single header to program any FPGA on your board as well as use a 
single header for Boundary Scan testing and programming. The ability to program multiple APA devices in a single pass significantly 
reduces the overall programming time of a system containing multiple APA devices. 

 Getting started 
Software installation 

ChainBuilder v1.1 is included in Libero v6.1 and automatically installs into the following program folder: Actel Libero IDE v6.1 -> 
ChainBuilder v1.1. You can also download ChainBuilder v1.1 from the web. 

To install the ChainBuilder software: 

1. From the InstallShield Wizard for ChainBuilder v1.1, click Next to see the license agreement. 

  
   

2. Click Yes, then Next to accept the license agreement. 

3. Click Next to install ChainBuilder to the default destination folder, as shown in the figure below. 
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4. To install to a different folder, click Browse and select another folder. ChainBuilder installs the software to the directory you select.  
 

 
 

5. Click Next to complete installation. 

The ChainBuilder software installs. 

Starting ChainBuilder 

You can start the ChainBuilder software from Programs->Actel ChainBuilder v1.1->ChainBuilder v1.1. If you installed the program 
in another folder other than ChainBuilder, choose that folder from the Programs menu. 

After you start ChainBuilder, the Welcome to ChainBuilder dialog box appears as shown in the figure below.  
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From the Welcome to ChainBuilder dialog box, you can open an existing project or create a new project. The Project to open field 
shows the name of the project file that will open, and the Recent opened projects field displays project names you have opened 
recently. See the table below for a description of each button in the Welcome to ChainBuilder dialog box. 
 

ChainBuilder Welcome Dialog Box Button Description 

Button Description 

 
Opens the Open Project dialog box so you can browse 
to find your project file. 

 
Opens the project listed in the Project to open field. 

 
Opens a Create New Project dialog box for you to 
save your new project. 

 
Cancels the Welcome To ChainBuilder dialog box 
and opens the software GUI. 

Creating a new project 

To create a new project: 

1. Click on the New Project button . 

2. Name your project file and designate where you want to save it. 

3. Click Save to save your project. 
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Opening a project 

To open a project: 

1. Click on the Open Project button .  
2. Find your project file from the Open Project dialog box. 
3. Click Open to open your project. 

Saving a project 

Whenever you update or make changes to your project, save your changes often. Use the Save button in the toolbar or from the File 
menu, click Save to save your project. 

If you want to save your project under a different name/path, use the Save As command under the File menu. 

Setting log window preferences 

Use the instructions below to change the text message color for your error, warning, informational, and linked button messages 
displayed in the log window. 

To set your log window preferences: 

1. From the File menu, select Preferences. The Preferences dialog box displays as shown in the figure below. 

2. Select a color from the Error, Warning, Informational, or Linked buttons drop-down menus to change your default color.  

3. Click OK to add the new color. 
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Right-click menus and hotkeys 

The ChainBuilder software has right-click menus and hotkeys for most functions of the software. For more information about these 
topics, see the ChainBuilder Tutorial. 

 ChainBuilder tutorial 
This tutorial demonstrates how to create a STAPL file that can be used to program APA devices that are part of a heterogeneous 
JTAG chain. This example uses two APA devices and two non-Actel devices configured as shown in the figure below.  
  

 

To create a new project: 

1. Double-click the Chainbuilder application on your desktop to launch it.  

2. From the Welcome to ChainBuilder dialog box, click the New button. The Create New Project dialog box appears. Select the directory 
where you want  to save the new project. 

3. In the File name field, enter the project name (Tutorial) (see figure below). 

4. Click Save. 

 

Next, you need to determine your chain order. 
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Determining Your Chain's Order 

Before proceeding, it is important to know how the devices are ordered in your chain. The graphic at the top left of the ChainBuilder 
workspace serves as a guide to determine the order in which the devices will be entered. See Figure below. 

 

For this tutorial, the APA300 is the first device in the chain, followed by a non-Actel device, etc. (Device 1 = APA300, Device 2 = 
non-Actel, Device 3= APA450, Device 4= non-Actel). See figure below. 

 

Adding an Actel device using the Add button 

Now you are ready to add your devices. This section describes how to add Actel and non-Actel devices. For this tutorial, we will add 
an APA300 device, two non-Actel devices, and an APA450 device. There are multiple ways of adding devices, and this tutorial 
demonstrates each method. 

Adding the APA300 Device Using the Add Device Button 

The first device you will add is the APA300 device.  

To add the APA300 device: 

1. Click the Add Device button . A submenu appears featuring the options Add Actel Device and Add Non-Actel Device.  

2. Select Add Actel Device. The Add Actel Device dialog box displays. Choose the APA300 device from the Device drop down menu. 
 

 
 
In the STAPL file field, load the APA300.stp file. Use the Browse button to locate the file.  

3. In the Name field, leave APA300 as the default. 

4. Click OK.  
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The APA300 device is added into the workspace as APA300. See figure below. 
 

 

Adding a non-Actel device using main menus 

The second device you add will be a non-Actel device. For the first non-Actel part, you will use the main menus to add the device. 

To add the Non-Actel device: 

1. From the Tools menu, select Add device, then click Add Non-Actel Device. The Add Non-Actel device dialog box appears (see figure 
below) so you can load the BSDL file or enter the IR length and Max TCK Frequency of the device. In this tutorial, you will load the 
BSDL file for this device. 
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2. Click the Browse button and select the device_2.bsd file (you will have to change the file of type filter on the Browse dialog and select 
BSD files in order to see the correct file). 

3. Name the device "Device 2" and click OK. The second device now appears in the ChainBuilder workspace. See figure below. 
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Adding an Actel device using the Right-click menu 

The next device you will add is the APA450 device using the Right-click menu. 

To add the APA450 Device using the contextual right-click menu: 

1. Right-click anywhere in the workspace. A menu appears.  

2. Select Import STAPL Files. The Import STAPL file browse dialog box displays. 

3. Locate and open the APA450.stp file. The third device is now present in the grid. 

Adding a non-Actel device using a hotkey 

The final device is the second non-Actel device you will add. For this device, you do not have the BSDL file available. However, you 
can still add the device because you know the Instruction Register (IR) length and the maximum TCK frequency. You will use the 
hotkey <CTRL-SHIFT-A> to add the final device. 

To add the second non-Actel device using a hotkey: 

1. Press CTRL+SHIFT+A. The Add Non-Actel device dialog box displays. Click inside the Data field. 

2. Enter the IR length and Max TCK Frequency of the second non-Actel device. In this example, enter 5 for the IR length and 8 for the Max 
TCK Frequency.  

3. Enter Device 4 in the Name field (see figure below). 

4. Click OK. 

 

Note: If you made a mistake when entering device names or chain order, you can go back and easily correct them now. See Modifying 

Device Information and Understanding the Organize Buttons for information on modifying the device order. 

As shown in the examples above, you can use the Add Device button, the Tools menu, the contextual menu, and hotkeys to add Actel 
and non-Actel devices. (You can see hotkeys for all the functions by browsing through the menus). 

Generating a chain STAPL file 

You now have a grid with all four devices in the correct order. Before you can generate your STAPL file you must first choose which 
devices you want to program. Notice the Program Device column in the figure below. 
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If you check the Program Device column checkbox, ChainBuilder programs that device in your chain. If you uncheck the Program 
Device column checkbox, ChainBuilder bypasses the device or devices in the chain, and no functions (such as programming) are 
performed on it. 

In this tutorial, you will program the APA300 and APA450 devices. Therefore, you must check the Program Device boxes for the 
APA300 and APA450 devices as shown in the figure above. 

To generate a Chain STAPL file for the APA300 and APA450 devices: 

1. Check the Program Device boxes for the APA300 and APA450 devices. See above figure. 

2. Click the Generate STAPL File button below the ChainBuilder grid. There are also menu options (Tools->Generate STAPL File) and a 
hotkey (CTR+G) to perform this function. 

Note:  Remember to check the Program Device checkbox for the APA devices you want to program. 

From the progress bar at the bottom of the window, you can see when the STAPL file is finished generating. The output in the log 
window informs you that the STAPL file was successfully created. Now you have a STAPL file ready to program the APA devices in 
your chain. 

 Understanding the ChainBuilder GUI 
The figure below shows the ChainBuilder software GUI, which consists of a menu bar, toolbar, ChainBuilder workspace, and a log 

window. 
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Understanding the chain order 

The devices you add to the chain must be in the correct order and must match the physical chain to be programmed. The TDO for the 
first device connects to the programmer, and the last device's TDI connects to the programmer. The devices in the chain go in order 
from a device's TDI into the next device's TDO, as shown in the figure below. 
  

 

Understanding the menu bar 

The menu bar consists of the following menus: File, Edit, View, Tools, and Help as shown in the figure below. 
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Use the File menu to create, save, or open a project. You can also import STAPL files, set log window preferences, and save and print 

the ChainBuilder grid from this menu.  

From the Edit menu, you can cut, copy, or paste devices as well as copy your ChainBuilder grid, and clear the Log window. For more 
information about copying, printing, and saving ChainBuilder grids, see Copying, Printing, and Saving the ChainBuilder Grid. 

From the View menu, you can select a Standard Tools, Status Bar, or Log Window view.  

From the Tools menu, you can add an Actel device or non-Actel device, configure a device, remove a device or move it up/down, or 

generate a STAPL file.  

The Help menu includes help topics, the user's guide, and information about ChainBuilder. 

Understanding the toolbar 

The buttons in the toolbar allow you to open, save, create a project, cut or copy a device, as shown in the figure below.  
 

  
  
The table below lists the toolbar buttons and their descriptions. 
 

Toolbar Button Descriptions 

Button Description 

 
Creates a new project. Opens the Create New Project 
dialog box. 

 
Opens a new project. Opens the Open Project dialog 
box. 

 
Saves a project. 

 
Cuts a device. 

 
Copies a device. 

 
Pastes a device. 

 
The About button. Gives a short description of the 
ChainBuilder software. 

Understanding the ChainBuilder workspace 

The ChainBuilder workspace consists of the Configuration button, Organize buttons, 

Add Device button, ChainBuilder grid, Output file field, and the browse button as shown in the figure below. 
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When you right click anywhere in the ChainBuilder workspace, a shortcut menu appears. 
  

 

Note:  The figure below shows the order of the chain only. For more information about chain ordering, see Understanding the Chain 

Order. 

 

Understanding the log window 

The log window consists of four tabs: Output, Errors, Warnings, and Info. After you configure a device or generate a STAPL file, 
click one of the tabs to check for important information about your device. Use the arrow on the scroll bar to move information up and 
down the log window.  

Copying, Printing, and Exporting Log Window Information 

You can copy, print, and export information from the log window. 
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To copy the information from the log window: 

1. Right-click anywhere in the log window. 

2. Select Copy from the shortcut menu.  

To print the information from the log window: 

1. Right-click anywhere in the log window. 

2. Select Print from the shortcut menu. 

To export information from the log window: 

1. Right-click anywhere in the log window. 

2. Select Export from the shortcut menu. 

3. Type in a name for your file in the Save As dialog box. 

Clearing the Log Window 

You can clear the log window from Edit menu->Clear Log Window or right-click anywhere in the log window and select Clear 
from the shortcut menu. 

Note:  You can also set your log window preferences to color code your display messages. 

 Using the ChainBuilder grid 
This section explains the IR length, Max frequency, and  how to use the ChainBuilder grid.  

Understanding the ChainBuilder grid 

When a project is loaded, the ChainBuilder grid displays your chain of devices and their configuration including their IR lengths, max 
frequencies, and Program mode (as shown in the figure below). 
  

 

IR Length 

The IR length specifies the number of IR (Instruction Register) bits in a specific device. By taking the IR lengths of all the devices, the 
ChainBuilder STAPL file can determine the position of each device in the chain and can correctly program the devices. 

Max Frequency 

The Max TCK is the maximum TCK (clock) frequency of a specific device. ChainBuilder can use this information to ensure that the 
programmer operates at a frequency lower than the slowest device in the chain. 
  

Note:  TCK must be a float number greater or equal to 1, and the IR length must be an integer number greater than or equal to 2. 
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Program Mode 

If you check the Program Device column checkbox, ChainBuilder programs that device in your chain. If you uncheck the Program 
Device column checkbox, ChainBuilder bypasses the device or devices in the chain, and no functions (such as programming) are 
performed on it. 

Browsing for files in the ChainBuilder grid 

To browse for a file in the ChainBuilder grid: 

1. Click the Browse button  in the File column in the ChainBuilder grid. 

2. Find your STAPL or BSDL file from the Use File dialog box. 

3. Click Open. 

Modifying device information 

You can modify the device name, file IR length, Max TCK, and Program mode by editing the cell.  

To modify a device you can either: 

• Click the black down arrow in the device column to open the Actel Device Configuration dialog box, enabling you to configure 
your device. 

• Select the device you want to modify and click the Configure button. 

• Directly modify the device information in the cell. 

Note:  Check for any error or warning icons in the device column. Click on these icons for additional information about the device 
errors or warning. 

Editing Spreadsheet Cells 

You can click inside the cells in the spreadsheet to edit device and file names, IR lengths, Max TCK, and Program mode by typing in 
the information. You can also click the browse button in the file column to browse for a file.

Note:  If the cell is gray, it is disabled and you can not make modifications to the device. 

Modifying the device chain 

You can delete devices in the chain or you can modify devices in the chain by moving them up or down. You can also move, copy, 
cut, and paste multiple devices in the chain.  

To move devices in the chain: 

1. Select the device you want to move in the ChainBuilder grid. 

2. From the Tools menu, click Move Down. 

Follow the same steps above to move your device up, but choose Move Up from the Tools menu instead of Move Down. 

To delete devices in the chain: 

1. Select the device you want to remove in the ChainBuilder grid. 

2. From the Tools menu, click Remove Device. 
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Copying, Cutting, and Pasting Devices in the Chain 

You can copy, cut, and paste devices within the chain. After you select a device in the grid, you can activate these commands by 
clicking the copy, cut, or paste icons from the toolbar or from the Edit menu, you can select the command you want the software to 
perform (Copy, Cut, Paste). 

Note:  You can also click on the organize buttons to delete your device or to move it up or down. See Understanding the Organize 

Buttons for a description of these icons. 

Selecting multiple devices in the grid 

Hold down the CTRL or SHIFT key to select multiple devices. 

Understanding error and warning messages 

An error or warning icon may appear next to your device in the device column in the ChainBuilder spreadsheet. See figure below.  
 

 

The yellow triangle icon means an error has been found, but you can still generate a STAPL file. A red icon means a fatal error has 
been found in the file configuration. You will get an error if you try to generate a STAPL file. 

Double-click an icon to get more information about the error or warning message; the information displays in the log window. The 
figure below shows an example of an error message. 
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Note:  Some error messages displayed in the log window are hyper-linked to the online help. 

Copying, printing, and saving the ChainBuilder grid 

You can copy, print, and save the ChainBuilder grid.  

To copy the ChainBuilder grid: 

1. From the Edit menu, click Copy Grid Selection. 

2. Paste the information in a Microsoft Word document or Microsoft Excel spreadsheet. 

To print the ChainBuilder grid: 

1. From the File menu, click Print. 

2. Select number of copies to print, and click OK. 

To save the ChainBuilder grid: 

1. From the File menu, click Export Grid to File. 

2. Name your grid and designate a location for it from the Save As dialog box.  

Note:  ChainBuilder saves your grid as a text (.txt) file.  
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 Understanding the Organize buttons 
The organize buttons enable you to select the order of the devices in your ChainBuilder software grid. You can move devices up and 
down or delete devices within the grid. See the table below for a description of each button. 
 

Organize Button Description 

Button Description  

 
Moves your device up in the ChainBuilder grid. 

 
Moves your device down in the ChainBuilder gird. 

 
Deletes your device from the ChainBuilder gird. 

 Adding devices 
This section describes how to add Actel and non-Actel devices. 

How to add a device 

Follow the steps below to add a device. 

To add a device: 

1. Click on the Add device button. 

2. Select either Add Actel Device or Add Non-Actel Device and click on it. 

Note:  You can add a device from the Tools menu --> Add Device, and you can also add an Actel device directly by importing a 

STAPL file. 

There are different requirements for adding Actel and non-Actel devices. For more information on how to add an Actel device, see 
Adding an Actel Device. For more information about how to add a non-Actel device, see Adding a Non-Actel Device. 

Adding an Actel device 

Follow the steps below to add an Actel device. 

To add an Actel device: 

1. Click on the Add device button and select Actel Device. 

2. Click on the drop down arrow in the Add Actel device dialog box. 

3. Find your device. 

4. If you want to use a STAPL file for your device (only necessary if the device is in Program mode), you can specify the file to use in the 

STAPL file field. Use the Browse button  to find your STAPL file.  

5. Click OK. Your device appears in the ChainBuilder grid. 

Note:  You can also specify a name and STAPL file for the device you add. 
 

22 
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When closing the Add Actel device dialog window, if you specified a STAPL file, it is parsed to check if it uses a good device. 

If you select a STAPL file, you must specify the correct device type otherwise you will get an error. If you do not know the type of the 
device the STAPL is related to, use Import STAPL file, and the device type will be recovered according to the file. 

You only can change the Program mode for some devices (APA and A3P/E devices). See Understanding the ChainBuilder grid for 

more information about the Program Mode  

Note: For more information on how to add an Actel device using the right-click menu or a hot key, see the ChainBuilder Tutorial. 

Adding a non-Actel device 

When adding a non-Actel device, you must choose either a BSDL file or customize the IR length and the Max TCK frequency of the 
new device.  

IR Length 

The IR length specifies the number of IR (Instruction Register) bits in a specific device. By taking the IR lengths of all the devices, the 
ChainBuilder STAPL file can determine the position of each device in the chain, and can correctly program the devices. 

Max Frequency 

The Max TCK is the maximum TCK (clock) frequency of a specific device. ChainBuilder can use this information to ensure that the 
programmer operates at a frequency lower than the slowest device in the chain. 

BSDL File 

BSDL (Boundary Scan Description Language) files describe the characteristics of a specific device. When using a BSDL file, 
ChainBuilder extracts the IR length and TCK frequency for the specific device and uses the information to build the ChainBuilder 
STAPL file. If you do not have a BSDL file for your specific device, you must manually enter the IR length and Max TCK for your 
device. This information should be found in the datasheet for the device. 

To add a non Actel device using a BSDL file: 

1. Click on the Add Device button and select Non-Actel Device. 

2. Insert a BSDL file by clicking on the BSDL file button. 

3. Select your BSDL file from the Use File dialog box, and click Open.  

4. Click OK, and your device displays in the software grid. 

When closing the Non-Actel Device window, if you specified a BSDL file, it is parsed and its IR length and Max TCK frequency are 
retrieved. 

Note:  If you select a BSDL file, you cannot specify an IR length and Max TCK frequency.  

To add a non Actel device using an IR length and a Max TCK frequency: 

1. Click on the Add Device button and select Non-Actel Device or right-click on a non-Actel device in the ChainBuilder grid and select Non-
Actel Device. 

2. Select the Data section by clicking inside the Data checkbox in the Add Non-Actel device dialog box. 

3. Specify the IR length AND the Max TCK frequency in MHz. 

4. Click OK. 

If you decide to use custom data, you must specify both an IR length and Max TCK frequency. 

For information about how to add a non-Actel device using the main menu or hotkey, see the ChainBuilder Tutorial.  
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Note: The IR length must be an integer greater than or equal to 2, and the Max TCK frequency must be a float greater than or equal to 
1. 

Importing a STAPL file 

You can import a STAPL file a few different ways. The steps below show you how to import a STAPL file from the File menu. 

To import a STAPL file from the File menu: 

1. From the File menu, click on Import STAPL Files. 

2. Find your STAPL file from the STAPL Files dialog box. 

3. Click Open. 

The STAPL file is added as a new device in the ChainBuilder grid. 

You can also import a STAPL file by right-clicking anywhere in the ChainBuilder workspace and selecting Import STAPL Files from 
the pop up menu or by using the hotkey, CTRL+I. 
 

Note:  You can import more than one STAPL file at a time. If you select multiple STAPL files, ChainBuilder adds multiple devices in 
the ChainBuilder grid.  

Device support 

ChainBuilder supports the following Actel devices in the Table below. 
 

ChainBuilder Device Support 

Family Devices 
APA075 
APA150 
APA300 
APA450 
APA600 
APA750 

ProASIC PLUS 

APA1000 
ProASIC3 A3P250 
ProASIC3/E A3PE600 

 Configuring a device 
This section describes how to configure an Actel and a non-Actel device. 

How to configure a device 

You can configure a device by clicking the Configure device button, by clicking on the black arrow next to the device name, or from 
the Tools menu click Configure Device. 

See Configure Actel Device, Configure Non-Actel Device, and Modifying Device Information for more information. 
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Configure an Actel device 

When you configure an Actel Device, the device type may be changed if the STAPL file changes. 

To configure an Actel device: 

1. Select a device from the ChainBuilder grid by clicking on it. 

2. Click on the Configure Device button to open the Actel Device Configuration dialog box. 

3. Modify the STAPL file you want to use, the device type, and name in the Actel Device Configuration dialog box. 

4. Click OK. 

Configure a non-Actel device 

You need a BSDL file or the IR Length and Max TCK frequency to configure a non-Actel device. 

To configure a non-Actel device: 

1. Select a device from the ChainBuilder grid by clicking on it. 

2. Click on the Configure Device button to open the Non-Actel Device Configuration dialog box. 

3. Enter the BSDL file or the IR Length and Max TCK frequency. 

4. Click OK. 

 Generating a STAPL file 
The Generate STAPL file button generates the specified STAPL file from the devices in the chain. Before you generate a STAPL 
file, you must specify the name of the STAPL file you want to generate in the output field as shown in the figure below. 
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Specify the name of the STAPL file you want to create by using the Browse button  

To generate a STAPL file: 

1. From the Tools menu, select Generate STAPL file. 

2. Or you can click on the Generate STAPL File button in the ChainBuilder workspace. 

You must have at least one APA or A3P/E device that is in the Program mode to satisfy the generate STAPL file condition. You need 
to program at least one device in the chain. 

 ProASIC3/E device support 
This section describes ProASIC3/E ChainBuilder device support.  

ProASIC3/E devices 

The ProASIC3/E devices, A3P250 and A3PE600 are featured in the Add Actel Device dialog box as shown in the figure below. 
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Note:  ChainBuilder v1.1 does not support serialization. 

ProASIC3/E devices support 

The ProASIC3/E Flash families consist of an FPGA array core, FlashROM (FROM) memory and a security header for the security 
features setting. You can securely program the FROM and the FPGA separately, which enables you to update the FROM without 
changing the FPGA core fabric. You can also generate a separate STAPL file with only the security header to set security features on 
the device. 

ChainBuilder v1.1 generates the output STAPL file based on the content of each input STAPL file. Each input STAPL file may 
contain any combination of the following: an FPGA array core, an FROM and security setting contents. Below is an example of how 
ChainBuilder v1.1 generates different STAPL files. 

Chain Configuration Example 

A chain configuration contains three PROASIC3/E devices where dev1.stp, dev2.stp and dev3.stp are the corresponding programming 
files that contain different content information. The table below shows the input files and the content for each device for this example. 
 

Device Input File and Content 

Input File Content 
Dev1 .stp Security settings for device 1 
Dev2 .stp FROM content for device 2 
Dev3 .stp FPGA Array content for device 3 
The output STAPL file is a single file that you can use to program the chain with the corresponding content from the input files. You 
also have the option of selecting the devices you want to program in the chain. 

 Troubleshooting 
Warning messages and error messages are included in this section. 

Warning messages 

Each warning message in this section includes a description of the message and an action for you to follow. 

Local copies 

This section contains a description and an action for the local copy warning message. 
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Description 

Every file (STAPL and BSDL) you use for a chain has a local copy. If your project is located in C:/MyFolder/Chain.chb, your local 
copies are stored in C:/MyFolder/Chain-Data. Every time you save a project, local copies are created. If ChainBuilder cannot find the 
original file you specified, it will use the local copy to generate the STAPL file. 

Action 

Make sure the STAPL and BSDL files used are available on your disk. See the section, How to configure a device. 

File not found 

This section contains a description and actions for the file not found warning message. 

Description 

You specified a STAPL file to use for a non-Programmed Actel device. ChainBuilder cannot find the file you specified, but because 
this STAPL file is not required for non-Programmed devices, ChainBuilder will simply ignore the file and acting as though you did 
not specify one. 

Note:   

• For programmed Actel devices, a STAPL file is required. 

• For non programmed Actel devices, a STAPL file is optional. 

Action Steps 

• Make sure the STAPL file you use is present on your disk  
• Do not use a STAPL file for a device that does not require one. 

See How to configure a device for more information. 

Error messages 

Each error message in this section includes a description of the message and an action for you to follow. 

Device and STAPL file mismatch 

This section contains a description and an action for the device and STAPL file mismatch error message. 

Description 

The error message is generated if you try to use a STAPL file with another device. If you generate a STAPL file for a APA750 device, 
you must use if for a APA750 device only. If you use it with any other device, an error message displays. 

Action 

Change the device or STAPL file you are using. 

See How to configure a device for more information. 
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IR lengths and TCK frequencies are not set 

This section contains a description and an action for the IR length and TCK frequency error messages. 

Description 

For customized non-Actel devices, please note the following requirements: 

• TCK and IR are both required. 
• TCK must be a float number greater or equal to 1. 
• IR must be an integer number greater or equal to 2. 

Action 

Modify the values in consequence. 

See How to configure a device for more information. 

Unknown device 

This section contains a description and an action for the unknown device error message. 

Description 

You opened a ChainBuilder project that references a device that ChainBuilder does not support anymore. 

Action 

Use devices that Actel supports. 

See How to configure a device for more information. 

File required 

This section contains a description and an actions for the file not required error messages. 

Description 

For Actel devices that are in Program mode, an error message occurs when you do not specify a STAPL file or if the one you specified 
cannot be found. A STAPL file is required for Programming Actel devices. 

Actions 

• For Actel devices, specify a valid STAPL file or uncheck “Program” mode. 
• For Non-Actel devices, specify a valid BSDL file. 

For more information, see How to configure a device. 

File cannot be parsed 

This section contains a description and an actions for the file cannot be parsed error messages. 
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Description 

The file specified for the device (BSDL if non-Actel device, STAPL if Actel device) cannot be parsed by ChainBuilder. 

Actions 

• Make sure the BSDL or STAPL file is valid. 
• Try to regenerate. 

Incorrect file type 

This section contains a description and an action for the incorrect file type error message. 

Description 

The STAPL file you specified for the Actel device does not have a valid extension. The STAPL file must have a *.stp extension. 

Action 

Use a file with the correct extension. 

STAPL files with non ProASIC devices 

This section contains a description and an action for the STAPL files with non ProASIC device error messages. 

Description 

Only ProAsic devices can use STAPL files. You are trying to use a STAPL file with a non ProAsic device. 

Action 

Do not use a STAPL file for non ProAsic devices. 
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