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Viewing Your Netlist 

Getting Started with NetlistViewer 

Starting NetlistViewer 
NetlistViewer is available from Designer main window. It can only be started after your design 

has been compiled.  

To start NetlistViewer from Designer, click NetlistViewer, as shown in Figure 1-1.  

If you have not compiled your design, Designer prompts you to perform the compilation process. 

  

 

Figure 1-1. NetlistViewer Button 

  

NetlistViewer reads your netlist design and generates a clearly laid out schematic view. 

Axcelerator and ProAsic family designs are displayed in the MultiView Navigator. All other 

designs are displayed in NetlistViewer as shown in Figure 1-2. 

  

Using the MultiView Navigator is described in Getting Started with MultiView Navigator. 
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Figure 1-2. NetlistViewer 

NetlistViewer 
NetlistViewer, as shown in Figure 1-3, consists of three windows: the Schematic View, 

Hierarchy View, and Search View windows. The NetlistViewer also contains a menu bar, 

toolbar, and status bar. Each of these items is described below. 
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Figure 1-3. The NetlistViewer With All Windows Open 

Schematic View 

The Schematic View window displays a graphical representation of the netlist. 

Design Hierarchy View 
The Design Hierarchy View provides easy navigation through the design hierarchy and gives a 

compact hierarchy overview.  

To view the Design Hierarchy View Window: 

  From the View menu, click Hierarchy. The hierarchy window opens. This window is 

sizable and dockable. 
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Figure 1-4. Hierarchy View Window 

Search View 

Use the Search window to search for instances, nets, and ports. For information on using the 

search view see “Search View” on page 14. 

To open the Search View window: 

  From the View menu, click Search Tool. The Search View window opens to the right of 

the Schematic View window, as shown in Figure 1-5.  

 

Figure 1-5. Search View Window 

 

The Search View window is sizable and dockable. 

Navigation 
You can navigate in the logical view of the design in two directions:  

Vertical 
You can navigate vertically if you have a hierarchical design. 

 

Use the Push and Pop commands, from the Schematic menu and the toolbar, to move through 

the hierarchical design. The Push command allows you to go one level deeper in the design 
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hierarchy. Pop is the reverse action, your view rises up one level. Note that these commands are 

available in standalone NetlistViewer, not in MultiView Navigator.  

 

Right-click anywhere in the NetlistViewer to open a right-click menu. This provides shortcuts to 

Push and Pop functions. 

 

The menu and toolbar also include a Top command that brings you back to the top level of the 

design hierarchy. 

 

All three commands can be accessed through keyboard shortcuts:  

   CTRL-P for Push 

   CTRL-O for Pop 

   CTRL-T for Top 

Horizontal 

Large designs might not fit in the window. When this occurs, NetlistViewer applies page 

splitting. 

 

Netlists that continue on another page are terminated by special symbols.  

 

 

Denotes that the netlist continues on the next page 

 

Denotes that the netlist continues on the previous page 

To follow the netlist, double-click the symbol.  

For more information, refer to “Navigating Through Your Netlist”. 

Menu Commands 
File Menu 
 

Print: Prints what is currently displayed in the NetlistViewer. 

Print Preview: Prints what is currently displayed in the NetlistViewer to a preview window. 

Print Setup: Sets up your printing options. 
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Close: Closes the NetlistViewer. 

  
Edit Menu 
 

Push: Displays the next lower level in the design hierarchy. 

Pop: Displays the next higher level in the design hierarchy. 

Top: Displays the top level of the design. 

Highlight: Marks the currently selected object by turning it red. 

Highlight Append: Highlights the currently selected object, by turning it red, and adds it to a 

group, which includes that last highlighted object. 

Unhighlight: Unmarks the selected object only, returning it to yellow or blue. 

Clear Highlight: Clears all marked objects, returning them to yellow or blue. 

  
View Menu 
 

Zoom Window: Allows you to drag out an area to enlarge. 

Zoom Fit: Fits design in NetlistViewer. 

Zoom In: Magnifies the view by a factor 2 (x2). 

Zoom Out: Reduces the view by a factor 2 (x.5). 

Redraw: Redraws the screen. 

Go to First Page: Takes you to the first page in the design. 

Go to Previous Page: Displays the previous page in the Schematic View window. 

Go to Next Page: Displays the next page in the Schematic View window. 

Go to Last Page: Displays the last page in the Schematic View window. 

Pre-optimized Netlist (Axcelerator Family): Displays the  

pre-optimized netlist in the Schematic View window. 

Optimized Netlist (Axcelerator Family): Displays the optimized flattened netlist in the 

Schematic View window. This is the default view. 

Toolbar: Hides or displays the toolbar. 

Search Tool: Hides or displays the Search window. 

Hierarchy: Hides or displays the Hierarchy window. 
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Getting Started with Multiview Navigator  

Starting MultiView Navigator 
MultiView Navigator is available from the Designer main window. It can only be started after 

your design has been compiled. MultiView Navigator is the user interface for NetlistViewer, 

ChipPlanner, PinEditor, and I/O Attribute Editor.   

To start MultiView Navigator from Designer, click NetlistViewer, as shown in Figure 2-1.  

If you have not compiled your design, Designer prompts you to perform the compilation process. 

 

 

Figure 2-1. NetlistViewer Button 

 

The MultiView Navigator reads your netlist design and generates a clearly laid out schematic 

view. Axcelerator and ProAsic designs are displayed in the NetlistViewer inside MultiView 

Navigator, as shown in Figure 2-2. All other designs are displayed in standalone NetlistViewer.  
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Figure 2-2. MultiView Navigator 

MultiView Navigator 
NetlistViewer, embedded in MultiView Navigator, as shown in Figure 2-2, enables you to select 

a Hierarchical view, Location view, and Information windows.  

 

The Netlist Viewer embedded in MultiView Navigator also contains a menu bar, toolbar, and 

status bar. These items are described below. 

Hierarchy window 

The Hierarchy window provides easy navigation through the design hierarchy and gives a 

compact hierarchy overview. You can chose to view the following types of elements: 

  Logical 

  Physical 

  Ports 

  Nets 

  Regions 

NetlistViewer window 
The NetlistViewer window displays a graphical representation of the netlist. 

Location view 

The Location view enables you to change the area displayed in the NetlistViewer window.  

To alter the position displayed in the NetlistViewer window: 

  In the Location view window, click and drag the display area. The position of the netlist 

in the NetlistViewer window changes. 
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Figure 2-3.   Using the Location view window  

Log Window 

The Log window displays information about your netlist. This area is also used to display the 

results of any search that you perform. Click the tabs at the bottom of the window to view the 

information you require. You can choose from: 

  Output 

  Errors 

  Warning 

  Information 

  Find (Search Results) 

Navigation 
You can navigate in the logical view of the design in two directions:  

Vertical 
You can navigate vertically if you have a hierarchical design. 
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Use the Push and Pop commands, from the Schematic menu and the toolbar, to move through 

the hierarchical design. The Push command allows you to go one level deeper in the design 

hierarchy. Pop is the reverse action, your view rises up one level.  

 

Right-click anywhere in the MultiView Navigator to open a right-click menu. This provides 

shortcuts to Push and Pop functions. 

 

The menu and toolbar also include a Top command that brings you back to the top level of the 

design hierarchy. 

 

Horizontal 

Large designs might not fit in the window. When this occurs, MultiView Navigator applies page 

splitting. Page splitting is optional; de-select Allow Page Splitting in the Schematic menu to 

turn it off.   

 

Netlists that continue on another page are terminated by special symbols.  

 

 

Denotes that the netlist continues on the next page 

 

Denotes that the netlist continues on the previous page 

To follow the netlist, double-click on the symbol.  

For more information, refer to “Navigating Through Your Netlist” on page 20. 

Toolbar 
The toolbars listed below are for the MultiView Navigator interface running NetlistViewer: 

Standard 
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View 

 

 

Logic 

 

 

Highlight 

 

 

 

Edit 

 

 

Schematic 

 

 

 

Menu Commands 
The menu commands below are for the MultiView Navigator interface running NetlistViewer. 

 Standalone NetlistViewer commands vary slightly from those listed below.  

File Menu 
Commit: Commits your changes to the design. 

Print: Prints what is currently displayed in the MultiView Navigator. 
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Print Preview: Prints what is currently displayed in the MultiView Navigator to a preview 

window. 

Exit: Closes the MultiView Navigator. 

Edit Menu 

Undo: Reverses your last action. 

Redo: Performs your last action again. 

Cut: Deletes your current selection and copies it to the clipboard. 

Copy: Copies your current selection to the clipboard. 

Paste: Copies the contents of the clipboard to your design. 

Select All: Selects all elements in your design. 

Find: Opens the Find window. 

Highlight: Highlights or Unhighlights your current selection. 

Highlight Color: Enables you to change the color used to highlight entities. 

View Menu 
 

Zoom In: Magnifies the view by a factor of 2 (x2). 

Zoom Out: Reduces the view by a factor of 2 (x.5). 

Zoom Window: Enables you to drag out an area to enlarge. 

Zoom Fit: Fits design in MultiView Navigator. 

Redraw: Redraws the screen. 

Toolbars: Enables you to show or hide the toolbars. 

Windows: Enables you to show or hide windows. 

Display Settings: Enables you to change the display settings.  

 

Schematic Menu 
Push: Displays the next lower level in the design hierarchy. 

Pop: Displays the next higher level in the design hierarchy. 

Top: Displays the top level of the design. 

Go to First Page: Takes you to the first page in the design. 

Go to Previous Page: Displays the previous page in the Schematic View window. 

Go to Next Page: Displays the next page in the Schematic View window. 

14 



 

Go to Last Page: Displays the last page in the Schematic View window. 

Follow Net Into: Enables you to follow your design through its various levels. 

Go to Net Driver: Enables you to jump to the Net Driver 

Select All Children in other Views: Enables you to select all the children of the current selected 

entity. 

Allow Page Splitting: Enables or disables page splitting in your view. 

Show Pre-optimized Netlist: Displays the pre-optimized netlist in the Schematic View window. 

Show Optimized Netlist: Displays the optimized flattened netlist in the Schematic View 

window. This is the default view. 

Tools Menu 
ChipPlanner: Launches ChipPlanner. 

PinEditor: Launches PinEditor. 

NetlistViewer: Displays your design in NetlistViewer. 

I/O Attribute Editor: Launches the I/O attribute editor. 

I/O Bank Settings: Enables you to change I/O bank settings. 

Window Menu 
New Window: Displays a new window. 

Close Window: Closes the active window. 

Cascade: Displays the windows in cascaded format. 

Tile Horizontally: Displays the windows in horizontal tile format. 

Tile Vertically: Displays the windows in vertical tile format. 

Arrange Icons: Re-arranges the icons on your screen. 

 

 

Using NetlistViewer 

Viewing Your Netlist 
The NetlistViewer window displays your netlist in a graphical manner, assisting you in 

debugging your netlist. 

To view your netlist using NetlistViewer: 
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  Start NetlistViewer. Click NetlistViewer in the Design Flow window. The NetlistViewer 

starts and displays your netlist in either MultiView Navigator (as shown below) or in 

standalone NetlistViewer.  

 

 

Figure 3-1. NetlistViewer 

Netlist Viewer in MultiView Navigator 
If your device supports Netlist Viewer in MVN (Axcelerator or Flash devices), you can choose to 

view the optimized flattened netlist or the pre-optimized hierarchical netlist. 

  The optimized flattened netlist is a non-hierarchical view. Use the optimized flattened 

netlist when cross-probing with other tools, such as PinEditor or Timer.  

  The pre-optimized netlist is the original netlist, as passed to the Designer software. The 

hierarchical structure is useful for navigating. When using the pre-optimized netlist for 

cross-probing, some items might not appear. 

To switch between the different views, from the Schematic menu, click Show Pre-optimized 

Netlist or Show Optimized Netlist. 
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Navigating Through Your Netlist 
You can navigate in the logical view of the design vertically and horizontally. This section 

describes both options. 

Vertical Navigation 
Navigate vertically through your hierarchical design by using the Push, Pop, and Top 

commands. These commands are available from the Schematic menu, the right-click menu, and 

the toolbar. They can also be accessed through keyboard shortcuts:  

  CTRL-P for Push 

  CTRL-O for Pop  

  CTRL-T for Top 

To go one level deeper in a design: 

1. Select an instance. 

2. From the Edit menu, click Push, or from the right-click menu select Push instance 

<name> 

To rise one level higher in a design: 

  From the Edit menu, click Pop. 

To rise to the top level: 

  From the Edit menu, click Top. 

Horizontal Navigation 

When large designs do not fit in the Schematic View window, MultiView Navigator applies 

page splitting. 

To navigate to the next page in a design do one of the following: 

1.  From the Schematic Menu, click Go to Next Page 

2.  Click the Next Page button in the toolbar 

To navigate to the previous page: 

1.  From the Schematic Menu, click Go to Previous Page 

2.  Click the Previous Page button in the toolbar 
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To navigate to the first page: 

1.  From the Schematic menu, click Go to First Page 

2.  Click the First Page toolbar button 

To navigate to the last page: 

1.  From the Schematic menu, click Go to Last Page 

2.  Click the Last Page toolbar button 

Following Nets 

Following a net might take you to the next page in a schematic, or several pages away.  

To follow a net: 

 In the Schematic View window, click a net that continues before or after the page being 

viewed. Nets that continue on a following page or pervious page are terminated by the 

symbols shown below. 

 

 

Denotes that the netlist continues on the next page 

 

Denotes that the netlist continues on the previous page 

   

In the example below, clicking the symbol next to sclk3m57_0 takes you to the page 

where the net continues. 

 

Figure 3-2. Symbol for a Continuing Net 

 

In the example below, clicking the symbol next to sclk3m57_0 takes you to the page 

where the net came from. 
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Figure 3-3. Symbol for Previous Net 

 

You can also navigate to the next or previous pages by selecting Go To Next Page or Go To 

Previous Page on the Schematic Menu. 

 

Using the Hierarchy Window - NetlistViewer in MultiView 
Navigator 
The Hierarchy window provides easy navigation through the design hierarchy and gives a 

compact hierarchy overview. When you select an instance in the Hierarchy window it is 

highlighted in the NetlistViewer window. MultiView Navigator enables you to view the 

following elements; Logical, Physical, Ports, Nets and Regions. Choose the type you want to 

view by clicking on the tabs at the bottom of the window. 

 

To view the Hierarchy window: 

1. From the View menu, click Windows and Hierarchy Window. The Hierarchy Window 

opens. 

2. Select the type of element you want to view by clicking on one of the tabs at the bottom 

of the window. 

3. Select an instance name in the hierarchy. The instance is located and highlighted in the 

NetlistViewer,as shown below. All parents are also selected. Since any item selected in 

one window is selected in all, selecting an instance in the NetlistViewer locates and 

selects the instance in the Hierarchy window. 
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Figure 3-4. Hierarchy View Window 

Highlighting Objects 
Highlight objects or groups of objects for easy reference. Highlighted objects are displayed in red 

by default but you can change this color. 

To highlight an object: 

1. Select the object in the NetlistViewer. 

2. From the Edit menu, click Highlight or click the Highlight button in the toolbar. The 

object changes from yellow or blue, to red, as shown in Figure 3-5.  
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Figure 3-5. Highlighted Object 

To highlight a group of objects: 

1. Select an object in NetlistViewer. 

2. Select another object to add to the group. Select multiple objects by holding down the 

SHIFT key while selecting. 

3. From the Edit menu, click Highlight or click the Highlight toolbar button. 

This can be useful for tracing a net,as shown in Figure 3-6. 

 

 

Figure 3-6. Highlighting Groups 

To unhighlight an object or group of objects: 

1. Select the highlighted object, or group of objects. To select a group, hold the SHIFT key 

while selecting objects with your mouse. 
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2. From Edit menu, click Unhighlight, or click the Unhighlight toolbar button. 

To change the highlight color: 

1. From the Edit menu, click Highlight Color. 

2. Select the color your require. 

3. Click OK. 

Searching 
This section describes how to search using NetlistViewer embedded in MultiView Navigator. 

 The search procedure for standalone NetlistViewer varies slightly from the one described here.  

 

Searching for objects can shorten your debug time. Use the Find window to search for instances, 

nets, and ports. 

To search for an instance, net or port: 

1. From the Edit menu, click Find. The Find Window opens,as shown in Figure 3-7.  

 

 

Figure 3-7. Searching  

 

2. Select Instance, Nets, Ports or Regions tab in the Find what area. 

Type the text you are looking for in the Name area. You can refine your search by 

specifying a Cell type (on the Instance tab), a Fanout value (on the Nets tab), a Port type 

(on the Ports tab) or a Region type (on the Regions tab). 
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The Name and Cell type fields accept regular expressions. Wildcards in regular 

expression include: 

  ? matches any single character 

  * matches any string 

  [ ] matches any single character among those listed between brackets 

  [A-Z] matches any single character in range A-Z 

  [Z-A] matches any single character in range A-Z 

  / is the level-bordering symbol. "A/B" designates "object B, which is part of instance A". 

Note that the level-bordering symbol cannot be put between brackets in a regular 

expression. 

3. Select search options. 

Click the Regular expression if you want to search using a regular expression. Click 

Match Case if you want the search to only return items with the exact characters 

specified. Click Select results if you want to automatically select items that match your 

search criteria. 

4. Click Find. The located objects, if any, appear in the Result pane. 

5. Select one or several objects in the Result pane to locate them in the Netlist Viewer 

window.  

Storing Search Results 

MultiView Navigator enables you to store your search results. 

To dictate how your results are stored: 

1. Click Advanced in the Find window. 

The Find window expands to display the advanced options as follows: 
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Figure 3-8. Find Window Showing Advanced Options 

 

2. Click the Pane radio button to select the pane into which your results will be stored or 

click New pane and enter a name for your new pane. 

3. Click the Overwrite previous results radio button if you want to overwrite any existing 

results or click the Append to previous results radio button if you want to append your 

results to any existing results. 

Using NetlistViewer with ChipEditor/ChipPlanner 
If both the NetlistViewer and ChipEditor/ChipPlanner are open, items selected in either tool 

are selected and highlighted in the other. For more details about ChipEditor, please refer to the 

ChipEditor Online Help. For more details about ChipPlanner, please refer to the ChipPlanner 

Online Help.   

 

The procedure described here is for tools embedded in MultiView Navigator.  Cross-probing 

with standalone NetlistViewer is supported in ChipEditor; the procedure varies slightly for 

standalone tools.  

To use NetlistViewer with ChipPlanner: 

1. Start NetlistViewer. Click on NetlistViewer in Designer’s Design Flow window. 
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NetlistViewer starts, displaying your netlist, as shown in Figure 3-9. 

  

  

Figure 3-9. NetlistViewer in the MultiView Navigator 

  

2. Start ChipPlanner. 

ChipPlanner opens in a separate window in the MultiView Navigator and displays the 

logic and I/O modules on the device, as shown in Figure 3-10. 

  

25 



Netlist Viewer User's Guide 

 

Figure 3-10. ChipPlanner Window 

  

3. Select a macro or instance in the ChipPlanner or NetlistViewer. The item is selected in 

the other tool, as shown in Figure 3-11. 

  

 

Figure 3-11. Item Selected in Both ChipPlanner and NetlistViewer 

 

26 



 

Using NetlistViewer with Timer 
Use the NetlistViewer with Timer to view and trace entire paths. For more detailed information 

about Timer, please refer to the Timer Online Help. 

Tracing Timing Paths 
The NetlistViewer with Timer enables you to trace Timing Paths.  

To trace paths using NetlistViewer and Timer: 

1. Start NetlistViewer. Click on NetlistViewer in Designer’s Design Flow window. 

  

 

Note:    Your design must be compiled in order to start NetlistViewer. If it is not compiled, 

Designer prompts you to do so. 

  

NetlistViewer starts, displaying your netlist as shown in Figure 3-12. 
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Figure 3-12. NetlistViewer 

  

2. Start Timer. Click Timer in Designer Design Flow window. 

 

 

Timer starts,as shown in Figure 3-13 . 

  

 

Figure 3-13. Timer Starts 

  

3. Click the Timer Paths tab. The Paths tab is displayed, as shown in Figure 3-14. 
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Figure 3-14. Paths Tab 

  

4. Select a path set in the path set table. Paths within that set are displayed below in the 

path table. 

5. Select the path you wish to expand in the lower path set table. 

6. Expand the path by double-clicking on the path, or in the Edit menu, click Expand 

Paths. The Expanded Paths window opens, as shown in Figure 3-15. 
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Figure 3-15. Expanded Paths 

  

 

The Expanded Paths window displays the path in the Expanded Paths grid and a 

graphical representation of the path in the Graph window. 

 

7. Select an instance in the Expanded Paths grid or in the Graph window. The instance is 

highlighted in the NetlistViewer, as shown in Figure 3-16. 
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Figure 3-16. Instance in Timer is Highlighted in NetlistViewer 

  

8. Select the first register in the timer path and locate it in the NetlistViewer. Follow the 

entire path in the NetlistViewer.  

Examples 

Debugging Simulation Results 
The NetlistViewer is useful for debugging your netlist when simulation results are complex or 

conflicting with design constraints. 

 

In this example, an unknown (red) signal appears as an output when simulation is performed, as 

shown in Figure 4-1. 

  

 

Figure 4-1. Investigating Signal Output 

 

In most cases, this occurs when the output of a flip flop is being fed back into the input without 

a reset, preset, or clear input. The NetlistViewer can help you verify that such a flip flop 

configuration exists in the design. 

Locating and viewing the flip flops: 
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1. Start the NetlistViewer. Click NetlistViewer in the Design Flow window. 

2. Zoom to locate the flip flops, as shown in Figure 4-2. 

  

 

Figure 4-2. Flip Flop Feedback 

Identifying Paths 
In this example, the NetlistViewer is used with Timer to identify the inputs of combinational 

gates. For more detailed information about Timer, refer to the Timer Online Help. 

To identify these paths: 

1. From Designer, start NetlistViewer. Click NetlistViewer in the Design Flow window. 

The NetlistViewer starts and displays your netlist,as shown in Figure 4-3.  
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Figure 4-3. Starting NetlistViewer 

  

2. From Designer, start Timer. Click Timer in the Designer Flow Window. Timer starts, 

as shown in Figure 4-4. 
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Figure 4-4. Starting Timer 

  

3. In Timer, click the Paths tab, as shown in Figure 4-5. 
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Figure 4-5. Timer’s Paths Tab 

 

The Paths tab displays timing analysis information for four categories of paths, known as 

“sets,” in the upper table. When a set is selected in this upper table, the paths within that 

set are displayed in the lower table. 

 

4. Select a path set in the upper path set table. The paths within that set are displayed in the 

lower table. 

5. Expand a path. Double-click a path in the lower paths table. The Expanded Paths 

window opens, as shown in Figure 4-6. 
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Figure 4-6. Expanding the Path 

 

The Expanded Paths window displays a path in the Expanded Paths table and a graphical 

representation of the path in the Graph window. 

Notice that the inputs of combinational gates are not displayed in the Graph window, as shown 

in Figure 4-7. 

  

 

Figure 4-7. Combinational Gates in Timer’s Expanded Paths Window 

   

It is useful to know where these paths come from, as they might indicate a false path, 

which is never encountered in the use of the design and can affect the timing report. It is 
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very useful to know the interaction of other inputs to these macros with the indicated 

path because this helps in defining the appropriate paths to get accurate timing reports. 

 

6. Select the macro in the Graph window. The macro is located and selected in the 

NetlistViewer, as shown in Figure 4-8. 

  

 

Figure 4-8. Selected Macro is Located and Selected in the NetlistViewer 

 

 

Using the NetlistViewer, you can now track the other inputs into the path. 

Viewing Buffers 
NetlistViewer is useful to see buffers inserted by your synthesis tool due to the high fanout 

number of some signals. 

To view inserted buffers: 

1. Start NetlistViewer. Click NetlistViewer in the Design Flow window. The NetlistViewer 

starts and displays your netlist,as shown in Figure 5-9. 
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Figure 4-9. NetlistViewer Starts 

   

In this example, since the fanout of DATAIN and RESET inputs of the design exceeds 

the specified value in the Synplicity synthesis tool, Synplicity inserts 2 buffers in their 

path to reduce the number of fanout for these signals, as shown in Figure 5-10. 
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Figure 4-10. Inserted Buffers 

Using NetlistViewer, you can track these inserted buffers.  
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